Several problems with data field names:
1) Some field names are not intuitive. Example: currently the time you are riding and not paused is called "Total Ride Time" while the time including pauses is called "Elapsed Time". This is the opposite of what I would expect. However about calling them "Moving Time" and "Total Time" instead?
2) For the default pages the corner of the power wheel says "3s Avg" while if you add the power wheel to a page the corner says only "avg". In both cases it is the 3s average. They should be consistent.
3) The default page says "Ride" for total ride time. If you add total ride time is says "Tot". They should be consistent.
There are probably more. The field names should make sense and have consistency between what they are called in setup and what they say on screen.