Stages Dash Public Feature Request Log

A place to request Dash features for the Stages development team.

INCORRECT REPORTING of Powermeter firmware version over ANT+

I'm running a Stages GenIII powermeter which is updated to the current firmware v.1.7.1 and Stages Link thinks it is "17.1", therefore telling me that I need to update my firmware.

  • K B
  • Dec 29 2020
  • Planned
  • Attach files
  • Red Shift commented
    7 Dec 08:21pm

    Same problem here.

  • K B commented
    22 Apr 04:31pm

    I have updated my power meter to the latest firmware and Stages Link is still telling me my Gen III power meter firmware needs to be updated.


  • Admin
    Kyle Oswald commented
    27 Jan 08:15pm

    Hello K B and thank you for finding this! I haver put a bug in for the team to resolve this issue. The web browser is handled by a third party though so this fix will most likely take some time.